Command Summary

From CameraBits
Jump to: navigation, search

All menus in Photo Mechanic follow certain conventions: A single menu item will directly execute a command e.g. Close. A menu item followed by an ellipsis (...) will bring up a dialog box with more options. A menu item with a small triangle to the right leads to a submenu with further choices.

File menu

File menu.jpg

New Window: Opens a copy of Photo Mechanic in a new window. Contact Sheet tabs may be moved between open Windows simply by dragging them from one window to another.

New Contact Sheet Tab...: Opens a new tab in the current Window.

Open contact sheet...: Choose a folder of images to be browsed.

Open Recent...: Choose from a list of recently opened contact sheets.

Close Window: Close currently displayed Contact Sheet Window.

Close Contact Sheet Tab: Close the current Contact Sheet tab.

Ingest...: Opens the Ingest dialog to copy images from external sources like CF cards.

Live Ingest...: Opens the Live Ingest dialog.

Live Slide Show: Opens the Live Slide Show dialog.

Remember Folders as a Favorite...: This command is only active when the current Contact Sheet tab is browsing multiple folders. When used, this command ‘remembers’ the set of folders as a Favorite in the Favorites panel.

Rename Photos...: Renames selected photos.

Copy/Move Photos...: Copies or moves selected photos to a new destination, photos can be renamed and IPTC Stationery can be applied.

Delete Photos...: Deletes selected photos from computer by moving them to the Trash or deleting them immediately. There is an optional confirmation dialog for this operation.

Save Photos as...: Saves photos in a variety of ways, with options for resizing, cropping, compressing and renaming.

Burn Photos to Disc...: Burn images to CD or DVD.

Send Photos via email...: Send selected images by email, with resizing, compression and renaming options.

FTP Photos as...: Transmits images by File Transfer Protocol to a remote server via the internet. There are options for sizing, compressing and renaming.

Upload: Sends images to your online accounts. There are options for sizing, compressing and renaming.

Export: Opens the Export dialog for HTML Web page creation or Text and XMP Exports.

Import GPS Coordinates...: Opens the Import GPS Coordinates dialog and allows you to import supported GPS log file formats onto your photos.

Page Setup...: Set up your printer for making Contact Sheets or Proofs.

Print...: Prints selected images as either a contact sheet view or a series of individual proofs. There are full layout and captioning options based on variables.

Edit Menu

Edit menu.jpg

Undo, Redo, Cut, Copy, Paste, Clear: These are the normal text editing functions common to all applications and are used when editing text in the various Photo Mechanic text boxes. All the usual text selection standards apply, such as double-clicking a word to select it.

Take IPTC Snapshot: Grabs the IPTC data from a selected image and copies it to a clipboard for pasting.

Paste IPTC Snapshot: Pastes the IPTC data to selected images.

Clear Transferred: Clears the Upload Status Indicators of the selected images. Find...: Finds images in the current selection or contact sheet by searching the file

names and/or metadata for specified words. Find and Replace...: Looks for and replaces, from a selection of the current contact sheet, metadata text in selected metadata fields.

Search...: Spotlight search. Select All: Selects all images in current contact sheet. Deselect All: Deselects any selected images.

Select Tagged: Selects all images that are currently Tagged.

Select Rotated: Selects all images that have been soft-rotated.

Select Transferred: Selects all images that have been uploaded.

Select Photos with Audio: Selects all images that have sound files associated with them.

Select Photos with GPS: Selects all images that have GPS coordinates applied to them.

Select Color Class: Selects all images of a particular Color Class. Select Rating: Selects images with a specified Star Rating. Select Date Range...: Selects all images in a particular date range. Select Others: Inverts the current selection to the images that are not selected.

Save/Load Selection: Saves out a text file with a list of the currently selected images. Load the text file to reselect the same images. This could be useful if you were to be sent a folder of images to make a selection from - just make the selection, save the selection and then you only need to return the selection text file, not the whole folder of images.

Settings submenu

  • Set Autocomplete...: Opens the ‘Autocomplete Settings’ dialog.
  • Set Code Replacements...: Opens the Code Replacement dialog.
  • Reload Code Replacements: Refreshes Code Replacements from recently saved Code Replacement files
  • Set GPS Home...: Opens the Set GPS Home dialog.
  • Set Info Text...: Opens the ‘Set Info Text’ dialog.
  • Set Sequence Variable...: Opens the ‘Set Sequence Variable’ dialog.
  • Set User/Client Variables...: Opens the ‘User/Client Variables’ dialog box.

FTP Connection Settings...: Opens the ‘FTP Connection Settings’ dialog.

Upload Connection Settings...: Opens the ‘Upload Connection Settings’ dialog.

Special Characters...: (Mac only) Opens a list of special characters to insert into metadata.

Image menu

Imagemenu.jpg

IPTC Stationery Pad...: Opens the IPTC Stationery Pad dialog.

Apply IPTC Stationery Pad to Photos:

Applies the current IPTC Stationery Pad to selected images. Keywords Panel...: Opens the Keywords Panel.

Structured Keywords Panel...: Opens the Structured Keywords Panel.

Rotate Photos CCW: Rotate selected images 90 degrees counter-clockwise.

Rotate Photos CW: Rotate selected images 90 degrees clockwise.

Tag Photos: Sets selected images as Tagged. Untag Photos: Untags any selected images.

Set Color Class of Photos: Apply a Color Class to the selected images.

Set Rating of Photos: Apply a Star Rating to the selected images.

Set GPS Coordinates...: Opens the Set GPS Coordinates dialog.

Preview...: Opens the Preview window with the selected images only.

Edit Photos: Launches the defined External Editor and opens the selected images for editing.

Send Photos to Droplet: If there are Photoshop actions saved as Droplets, the selected images are sent to a droplet specified in the submenu.

Slide Show...: Starts a Slide Show of the selected images.

View Menu

Viewmenu.jpg

Combined RAW+JPEG: Toggles on and off the combined RAW+JPEG option where available.

Unknown files as proxies: Shows ‘proxy’ thumbs of unknown files rather than not showing them at all.

All: Displays all the thumbnails in the contact sheet. Turns off any Rating or Color Class filters.

Selected: Views only the selected images and hides any unselected ones.

Tagged: Views only the Tagged images and hides the rest.

Untagged: Views only the images that have not been tagged and hides the rest.

Refresh: refreshes the display to reflect any changes to Tagging and Selections.

Rescan: will check the folder or folders for any new images that have been added.

Make Arrangement: makes an arrangement from the current order of the thumbnails.

Show Info Tooltips: Toggle on and off the Image Info Tooltips which are displayed in the Contact Sheet View when the cursor moves over a thumbnail.

Cursor Mode submenu: Allows you to choose between the two cursor modes: Loupe and Selection.

Hide/Show Toolbar: Hides or shows the Toolbar for more viewing real estate. Clicking the button in the extreme top right of the window does the same thing.

Customize Toolbar...: Same as right-clicking (Ctrl-clicking) the Toolbar to customize the Toolbar.

Tools menu

Toolsmenu2.jpg

These tools are a little more involved, so we will look at them closer here:

Adjust Capture Dates and Times

This tool will adjust the capture dates and/or times of the selected group of photos. The capture date/time is the time stamp written by the camera, usually stored in the EXIF data of a photo.

Oftentimes the clock in a camera may be off, sometimes by a little, and sometimes by a lot. The most common example is when you change time zones and forget to change the clock on the camera. The capture times recorded are therefore still relative to the original time zone (e.g. before you went on vacation).

For multiple camera environments such as sporting events, it is often critical to synchronize all the cameras down to the second if photos from multiple cameras are to be viewed together.

This tool can be used to either “Adjust Relative” or “Adjust Absolute”.

If you know your camera clock was off by some time delta (e.g. three hours since you changed three time zones), simply dial in the delta time (or even days) in the Adjust Relative section. For example, if you live in Boston and you went to vacation or work in San Diego without adjusting your camera clock, then set the Hours control to -3 to adjust the capture times of the photos from the Eastern to the Pacific time zone.

To precisely adjust the capture times, use the Adjust Absolute controls to set the absolute time a photo was taken. For example, with multiple cameras at a sporting event, make sure all cameras take a photo of the game clock (or some other common clock that shows seconds). Then select the photos from one camera, locate the photo of the clock using the arrow buttons under the photo, then dial-in the actual capture time of the photo shows using the controls to the bottom-right of the photo. A relative time will be calculated from that photo and applied to all the selected photos.

With the three checkboxes at the bottom you can also choose to update the file system’s creation and/or modification date/time, or the IPTC/XMP date/time.

All selected photos will be adjusted accordingly when the Adjust button is clicked.

Remove Crops

This tool will let you remove at once the soft crops that have been added to multiple photos.

Update IPTC/XMP

Updateiptc.jpg

This tool will update the IPTC/ XMP metadata in the selected photos, according to your IPTC/ XMP preferences. Photo Mechanic will first read IPTC or XMP according to your reading preferences, then it will write IPTC and/or XMP according to your write preferences. This tool is useful for synchronizing the metadata in RAW+JPEG pairs, or for embedding IPTC/XMP data into TIFF-based RAW photos based on IPTC/ XMP metadata in a JPEG.

For example, with this tool you can:

1) Update the XMP from the IPTC in JPEG, TIFF or Photoshop PSD photos.

IPTC/XMP Preferences for JPEG, TIFF, and PSD photos:

A) When reading IPTC/XMP, choose “Read embedded IPTC before XMP.”

B) When writing IPTC/XMP, check “Add embedded IPTC4XMP.”

2) Create XMP sidecar files from embedded IPTC in RAW photos or vice-versa. IPTC/XMP Preferences for RAW photos: A) When reading IPTC/XMP, choose “Read embedded IPTC” from the “First:” popup menu B) When writing IPTC/XMP, check the option to: “Always create and/or update XMP sidecar files with IPTC/XMP.”

3) For RAW+JPEG pairs, update the IPTC/XMP in the RAW photos from the IPTC/XMP in the JPEGs (or vice versa.)

A) To update RAW photos from JPEGs, in the Update IPTC/XMP dialog, choose the “Read IPTC/XMP from JPEG” option “For RAW+JPEG pairs.”

B) To update JPEGs from RAW photos, in the Update IPTC/XMP dialog, choose the “Read IPTC/XMP from RAW” option “For RAW+JPEG pairs.”

4) Embed IPTC/XMP into TIFF-based RAW photos from the Mac IPTC-NAA resources (Mac only.) IPTC/XMP Preferences for reading IPTC/XMP: Check the “Read IPTC-NAA Resources” option. IPTC/XMP Preferences for writing IPTC/XMP in TIFF-based RAW photos: Check the “Add embedded IPTC” and/or “Add embedded XMP” options.

Convert IPTC Text Encodings

Convertiptc.jpg

This tool converts text in IPTC records from one text encoding to another. This is useful if you’re changing OS platforms or using your photos with a particular application that insists on using a particular text encoding.

Convert RAW to DNG

Converttodng.jpg

This tool will use an installed instance of the free Adobe DNG Converter application to convert supported RAW formats to the DNG format.

To use this tool you must first have the DNG Converter installed on your system which you may obtain from Adobe for free. Next you need to use the ‘Pick DNG Converter...’ button to find and choose the DNG Converter application. Once it is setup in this manner you may set your options according to your needs (you can read more about the options in the actual DNG Converter application.) If you want your DNG files to be written next to the original RAW file then check the ‘Output to source folder’ checkbox, otherwise you will be prompted to choose a destination folder where all of the DNG files will be written. Lastly, click the ‘Convert’ button and your RAW files will be converted one-by-one to the DNG format according to your settings.

Delete Metadata...:

Deletemetedata.jpg

This tool will permanently remove each metadata type whose checkbox is currently set. This operation cannot be reversed. Once the metadata is removed it cannot be recovered. If you want to temporarily hide metadata, use the Mask/ Unmask... command instead. Note that Exif data cannot be removed from RAW files even if the ‘Exif*’ checkbox is set. Other image types in your selected set, for instance, JPEGs will have their Exif data removed when the ‘Exif*’ checkbox is set.

Revert TIFF-based RAW to original:

Reverttiff.jpg

This tool acts as a safety net since some RAW applications have been known not to read RAW files for which the metadata has been externally edited. This tool reverts the file back to its original form. Use the ‘Backup IPTC/XMP to XMP sidecar files’ checkbox if you want to keep a copy of your caption in a sidecar file. You can use the sidecar file to reapply the caption data later if you choose.

Mask/Unmask...:

Maskunmask.jpg

This tool will mask or unmask certain types of information from JPEG,TIFF, PSD, and TIFF-based RAW photos. Data that is masked is not deleted, and can be unmasked to retrieve the original info (except as noted below). Masking simply hides the data from most applications by changing the normal tags or resource IDs to something different. Unmasking restores the normal tags or resource IDs.

Masking data can be useful to diagnose certain workflow problems. For example, if you suspect that some other application is having problems with embedded XMP data within a photo, you can mask the XMP data for a photo (or group of photos) and see if this fixes the problem. If masking XMP data fixes the problem, you can choose to not embed XMP into photos in the IPTC/XMP preferences. If that doesn’t fix the problem, you can unmask the XMP and look for another cause.

Special notes:

  1. EXIF info and ICC profiles cannot be masked in RAW photos.
  2. If you mask IPTC and/or XMP in a photo and then add new IPTC info, you won’t be able to mask or unmask IPTC and/or XMP because both masked and unmasked data exist. The same is true for ICC profiles in JPEGs.

Change Resolution...:

Changeresolution.jpg

This tool sets the resolution for the file so it can be read by other printing applications. This does not make any changes to the file size, simply to the dpi information contained in the file.

Embed ICC Profile into JPEGs...:

Embedicc.jpg

This tool embeds or tags a selection of files with a specified ICC profile. Be careful when you use this, since it simply tags the file with a profile, it does not convert the image to that profile.

Apply Rotation to JPEGs:

Photo Mechanic does not generally rotate files, it simply displays the thumbnails in the correct orientation. Using this option on JPEGs applies the soft rotation to the files in a lossless manner so that the images will appear with the new orientation when opened in other applications which do not recognize soft rotations or EXIF orientation data. Once you’ve used this tool a few times and don’t want to see the confirmation dialog, holding down the modifier key will bypass the dialog.

Extract JPEG Previews from RAW photos...:

Many RAW files contain preview JPEGs created by the camera at the time of capture. Often these files are of sufficient quality for small uses, such as for the web, and being able to extract them means the whole RAW files does not have to be processed just to create a small image.

The new file will have the same name as the original, with all the settings for the original can be carried over using the three check box options.

The size of the extracted file depends on the camera model: some cameras only produces images for display on the camera’s rear screen so these will be very small.

Remap

Remap.jpg

Remaps Color Class to Star Rating or vice versa. This is very useful for images that have been previously allocated color classes but which may need to be viewed in another application - such as Bridge - with the ratings visible. Bridge can only ‘see’ Photo Mechanic Color Classes if the label names are the same, but the Star Ratings are directly compatible. You can choose which Colors are mapped to which Star Ratings depending on how you have chosen to use Color Classes in the past.

Then Set Rating/Color Class to: once the settings have been mapped across you can choose to have all the remapped images set to a particular Rating/Color Class afterwards. This is useful to see which have been remapped or to reset them to a value that you like.

Window

These commands govern how the program window appears. If you have multiple Photo Mechanic windows open, here is where you can switch between them.


Help

This menu contains links to various documentations of Photo Mechanic, including within the program, or the online documentation.

  • Photo Mechanic Help: This will open up this manual as included in Photo Mechanic (Works even if you are offline)
  • Photo Mechanic Online Manual: This takes you to the online version of the manual will may be more up to date than the one included with your instance of Photo Mechanic. However, the online version may also apply to a newer version of Photo Mechanic than what you have installed
  • Photo Mechanic Support Forums: This is a link to an online customer forum where you can interact with the program developers and other power users to ask questions and make feature requests


  • Licensing
    • Enter New License: Use this if you are entering a license that you have purchased after using Photo Mechanic on a free trial
    • Deactivate computer: Use this if you are decommissioning or discarding a computer and wish to free up its activation to install Photo Mechanic on a new computer


  • Software Update: Checks Camera Bits' servers to see if there is an updated version of Photo Mechanic available. You can specify how often tocheck for updates, or stop checking altogether
  • Reveal Support Data: Use this if directed by Camera Bits Tech Support when submitting a support request
  • Download Team Help client application: This will take you to a page where you can download software to help Camera Bits Tech Support troubleshoot issues on your specific computer. Use this when directed by Camera Bits Tech Support.