Frequently Asked Questions

From CameraBits
Jump to: navigation, search

Just the FAQ!

Why should I upgrade to Photo Mechanic Version 5?

Answer: The top 5 reasons are:

  1. Get full compatibility with the latest version of Mac OS X* If you have a new Mac, you’ll definitely need Photo Mechanic Version 5.
  2. Start ingesting photos as soon as you plug in a memory card with the new Auto Ingest feature.
  3. Take advantage of dozens of new IPTC/XMP fields that are now available. Customize the order, label, and visibility of each one.
  4. Save IPTC info, upload file, and move to the next – all with one click!
  5. Keep a Preview window open while you continue to browse a contact sheet.


Send Photos to Photoshop?

I used to be able to send my photos from Photo Mechanic to Photoshop but the new version doesn’t seem to work. What do I need to do?

Answer: Photo Mechanic is no longer tied to the full versions of Photoshop. You can use any image editing application now. The path to the secondary application will be set in the Preferences on the Launching page. Photo Mechanic’s preferences can be accessed from the Photo Mechanic menu (Mac) or the Edit menu (Windows )

Select the radio button at the top section to Assign default application and then click the “Choose...” button to the right of the field. This will open the Application picker dialog so you can locate the Photoshop application. See the path below for a default install location of the Photoshop application.

Windows:
C:\Program Files\Adobe\Photoshop xx\Photoshop.exe

Mac OS X:
/Applications/Adobe Photoshop xx/Adobe Photoshop xx.app

Highlight the Photoshop application and then click on the Open (Mac) or OK (Windows) button to set the path and return to the Photo Mechanic preferences. You should now see the path displayed in the field.

Opening Photos in Photoshop?

I have set the path to the Photoshop application but I still can’t get my photos to open in PS CS. Photoshop opens but never displays the images. What setting did I miss?

Answer: This sounds like the Photoshop application needs to be re-installed. Try this quick test to make sure. Quit both Photo Mechanic and Photoshop CS. Locate a JPEG file on your Desktop and drag its icon to the Photoshop icon in the Dock. If Photoshop launched but never opens the photo, then you will need to re-install Photoshop CS.

Upgrading to a New Version?

I am a bit apprehensive about upgrading my older version of Photo Mechanic the latest Version 5 because it seems so different. I've tried the demo and I can’t make it work like I'm used to. Do I have to learn a new set of commands for the new version?

Answer: Photo Mechanic Version 5 has a wide variety of customizable behaviors. This means that you should be able to configure it to behave like you're used to. Hopefully this manual will help you understand the different customizations.

Network Attached Storage (NAS) drives

I have a NAS drive attached to my Mac but it does not show up in Photo Mechanic's Navigator. Finder does see the drive. It is listed by name under "Shared" but does not have a drive letter/number. I tried to access the images via other programs and had no problem accessing all the files. What is wrong?

Answer: Photo Mechanic will only "see" mounted volumes. In OS X, you can usually do this just by clicking on the drive in Finder, and you'll be logged in and mounted. Then it should be accessible with Photo Mechanic

Browsing PSD Files?

I have seen other Photo Mechanic users work with PSD files. When I try to browse my PSD files, all I see is a blank thumbnail box. Is there some patch or plugin I need to install?

Answer: Photo Mechanic can only render Photoshop PSD files that have a flattened preview within them. If the PSD files are not saved from Photoshop with the Maximize Compatibility option enabled, then you will see a blank thumbnail. If you do not see the Maximize Compatibility dialog open in Photoshop when saving a new PSD file, then go to Photoshop’s preferences on the File Handling page and set the Maximize PSD and PSB File Compatibility to either Ask or Always.

Purchased After Demo?

I purchased Photo Mechanic via email. When I try to register my demo with the permanent password, it comes up as invalid. Do I need to re-install the Photo Mechanic application?

Answer: Photo Mechanic’s registration dialog is very strict about the text entered. You must type the text in exactly as shown in the email or on the registration certificate. One extra character or blank space will invalidate the password.

If you have copied the text from the email, then you could have pasted in hidden characters that will also invalidate the password. Photo Mechanic will, remember these hidden characters the next time you try to register it. The solution is to clear the registration dialog fields first and then type in your registration info. To clear the field, just use the Tab key or Shift Tab to backup one field. When the field is highlighted, hit the Delete key and then type in the required text. If your registration info does not have a department, then make sure to leave that field empty.

Expired Thumbnails?

I am trying out the Photo Mechanic demo and one of my photographer’s images all say Expired in a black thumbnail box. Is that camera broken?

Answer: The Expired Thumbnails will be displayed any time the capture date of the photo is beyond the expiration date of the Photo Mechanic demo. This can be fixed by using the Adjust Capture Dates and Times from the Tools menu.

Where Did My Photos Go?

I am using the Ingest utility to copy my Flash card photos to a folder on the local hard drive. When I click the Ingest button I see a small dialog open for just a second and then disappear. I have checked the box to open contact sheet during Ingest but all that opens is a blank gray window. Where are my photos?

Answer: If you have selected the “Copy Locked files Only” menu item in the Ingest dialog, then Photo Mechanic will only copy the files that have been locked by your camera. If you have not locked any files, then nothing will be copied by Ingest when this box is checked.

Ingest Copy Errors?

I'm using the Ingest utility to copy and rename all of my photos to the hard drive and make a secondary backup. The Ingest progress bar starts to move as normal and then I see a bunch of copy errors list in the dialog. What could be the problem?

Answer: If you don't use a rename string that will generate unique names for all of the photos, then Photo Mechanic will append a letter (A~z) to the end of each new file with the same name until all 26 letters are used. All the remaining files will now flag a copy error since you are not allowed to have two files with the same name in the same folder.

The solution is to use the Sequence variable somewhere in the rename string. Most people place the sequence variable at the end of their filenames. Make sure to Set the sequence variable to the correct value before renaming your photos. Make sure to allow enough leading zeros to cover all of the photos. Don’t set the sequence value to 01 if you have more than 99 photos to copy. If you do that then once the third digit is added to the sequence value, you’ll find that sorting by Filename will not display the photos in the correct order.

Spell Checker Dictionary?

How do I change the default dictionary used by the Spell Checker?

Answer: (Mac OS X) In System Preferences>International>Language make sure that the desired language (e.g., Canadian English) is in the list of languages. If it isn’t, click edit and edit the list. This controls what dictionaries are available as choices for spell checking. (But it does not select the language used for spell checking.) You can also edit the language list order so that the one you always use or use most is at the top of the list. Close system preferences.

Start Photo Mechanic. Open a contact sheet with some images. Put the cursor over an image and click its info button. Put the cursor in the Caption area and click to make Photo Mechanic think you are about to enter some text it should spell check. Click Edit>Spelling>Spelling... In the spelling popup window select the language you want. Close the windows. Close Photo Mechanic. Run Photo Mechanic again and you should have your desired spelling dictionary as the default. (Thanks to Roy Smith for this solution.)

On Windows, you can change the dictionary from the IPTC/XMP tab of the Preferences dialog. Please note that the spell checker built into the Windows version is currently incompatible with Unicode characters and if enabled, it may interfere with some languages. Turn off the spell checker if you experience difficulties.

Costco Photo Center Failed

I’m having difficulty uploading images to Costco Photo Center because their uploader says ‘Failed Photo’ on each image thumbnail. How can I fix this problem?

Answer: Select the photos you want to upload in the Contact Sheet. Use the Delete Metadata command on the Tools menu. Set only the ‘Photo Mechanic end of file preferences’ checkbox on. Click on the ‘OK’ button.

Now when you use the Costco Photo Center uploader you’ll no longer see that error and you can upload your photos.

Clean up Ingest dialog?

The Ingest dialog often shows drives I never want to Ingest from. How can I permanently remove those drives from the list?

Answer: All you need to do is create a folder named: PMIngestIgnore on the root of each drive that you want Photo Mechanic’s Ingest feature to ignore. You can do this with the Finder (Mac OS X) or with Windows Explorer (Windows.). You can also create a hidden file called .PMIngestIgnore (with a dot as the first character), though some operating system settings may affect your ability to create hidden files in this manner. For example, in OS X, you might need to rename the file in Terminal.

Check for Updates annoying?

The Check for Updates mechanism asks me to check for updates every day I startup Photo Mechanic. Is there some way I can disable this or check less often?

Answer: The ‘Software Update...’ command on the application menu (Mac OS X) or Help menu (Windows) will allow you to adjust those parameters to be less bothersome. You can change the frequency of the updates checking, or disable them altogether.

Snapshots location?

I use the Snapshots facility in various dialogs quite often but sometimes I find that I don’t want some of my Snapshots anymore. Where are the Snapshots located?

Answer: If you hold down the Modifier key (Option on Mac OS X, Shift on Windows) while you select one of your Snapshots, then your OS will open (Finder on Mac OS X, Windows Explorer on Windows) one of its windows and show you the Snapshot you selected. From there you can rename, duplicate, or delete your Snapshots.

Thumbnails matching other programs

My thumbnails don't look like they do in Lightroom. Why not?

Answer: Photo Mechanic uses the embedded Jpeg preview in the Raw files for the thumbnails and large previews. Some programs, like Lightroom, will render the raw data and using a color profile like ProPhoto RGB. Sometimes there can be a difference between the look in these two methods. You will need to use the controls in the Develop module to adjust the Raw image to match the embedded Jpeg generated by the camera.

Photo Mechanic and iPhone

When I plug my iPhone into my Mac, Photo Mechanic opens up. How can I stop this?

Photo Mechanic currently does not ingest photos off the iPhone or iPad. If PM is opening when you plug your devices is, it might be because of Image Capture. When your device is plugged in, open Image Capture, select your device on the left, and change the application that opens up in the menu at the bottom.

Uninstall Photo Mechanic?

How do I uninstall Photo Mechanic?

Should you need to uninstall Photo Mechanic, it is in your best interest to deactivate the program so that it does not count against future installs. If you purchased Photo Mechanic after October 2013, you should be able to do that via the Help menu in the program. If you purchased Photo Mechanic before Oct 2013, please contact support to walk through the steps to deactivate your computer. Then, follow the standard uninstall process for your operating system. On Apple OS X, you can go into your Applications folder and drag the program icon to the trash. On a Windows system, you can go into your Control Panel to the "Add/Remove Programs" utility. On Windows, you also have the option of running the original PM5Setup.exe (if you still have it) and choosing the "Uninstall" option.