Preview Window

From CameraBits
Jump to: navigation, search
Keyboard Shortcut
Open Preview Window

Mac: ⌘-R
Windows: Ctrl-R

In addition to the Contact Sheet view, Photo Mechanic can display one or two images at a time for closer scrutiny when editing. The image can be viewed zoomed up to 800% to check critical focus or chromatic aberration. Various information about each image can be displayed alongside each image, or the image can be viewed on its own in full screen mode. New in Photo Mechanic 5: The Preview window can remain open while you work in a Contact Sheet. This is especially useful for large displays or with multiple displays.


Previewwindow.jpg


To Preview an image simply double click on its thumbnail in the Contact Sheet window or click the magnifying glass icon at the lower right of the thumb when the mouse is hovered over it. There are three distinct Preview window styles. Each can have the various information panels toggled on or off making a total of six combinations of views. The views can be selected from the toolbar at the top of the screen.

Tools

These tools in the Preview Window operate on the photo that you're currently looking at. Here's what each tool does:

Preview tools.jpg

You can customize which buttons appear and in what order they are by right-clicking or ctrl-clicking in an empty area of the toolbar and selecting "Customize Toolbar."

Views

Views of the Preview Window

You can customize the Preview window's view with the buttons near the top of the window.

  1. View One Photo.
  2. View Two Photos, side by side for comparison.
  3. View Two Photos, one over the other.
  4. Toggle thumbstrip along the side or along the bottom
  5. Restore Panes
  6. Full View

Each view can be used ‘full-screen’ or with the info panels and thumbs list displayed. The info displays can be sized by click-dragging the splitter at the edge of their frames. They can be ‘collapsed’ by double clicking the splitter between the frames.

Images Side by Side

Keyboard Shortcut
Single Image:
O
Side-by-side:
H
Over and under:
V
Toggle Full Screen or Info Palettes:
F
Toggle Focus between previews:
Tab

Here are two photos displayed ‘over and under’ for comparison. The H key and V key toggle between a ‘side-by-side’ layout and an ‘over-and-under’ layout. Return to a single image view using the O key.

Two Photos side by side for comparison, with Info displayed: click once on either image to bring it to ‘focus’ with respect to the Information displayed in the Histogram etc. ‘Tab’ will toggle focus between the images.

Previewsideover.jpg

Info Panel

The Info Panel in the Preview window shows EXIF and IPTC information for each image such as date, ISO used, aperture etc. The list can be made longer or shorter by clicking on the plus and minus signs at the top right of the Info panel.

You can also customize which info is displayed, and the order of display, by using the Set Info Text command on the Settings submenu on the Edit menu. Edit this list to change the sequence of variables displayed in the Info Panel as well as the fields displayed. See Info Variables.

You can also use the Snapshot icon to save different Info Panel configurations and switch quickly between them.

The Info Panel and the Crop tool are found in the Preview window
Control the information that's displayed under Edit > Settings > Set Info Text...

Crop Tool

Keyboard Shortcut
Crop Tool
c
Below the Info Panel is the Crop tool which allows part of the image to be cropped when the image is saved, uploaded or otherwise exported. This is a non-destructive crop, which means the original file is unaffected when the cropped version is exported.

Click the Crop icon button to activate or deactivate the Crop Tool. Use this to define a crop area by click-dragging in the main preview window, just like in other image editing software. Once defined, the Crop area can be repositioned - the Crop tool changes to a Hand when the mouse cursor is within the defined crop area - click-drag to reposition the defined crop area. The cursor will change to a Rotate tool when outside of the crop area, or near the corners of the crop area. This allows you to rotate the image if it needs some straightening. Holding down shift while rotating makes it snap to 45-degree angles. See the Crop Tool in action here: Crop Tool Example

Nudging Crops

Modifier-arrows while the Crop tool is active allow movement of the crop. Holding down the Shift key on Mac or Ctrl key on Windows and using the arrow keys will move the crop by ten pixels at a time.

Reproducing Crops

From a Contact Sheet:

You can copy a crop from one image and reproduce it on another single image or batch of selected images. You can use the contextual menu from a contact sheet. Right-click on a thumbnal with a crop and choose Crop > Copy Crop. Then select other images, right-click them.

  • Paste Crop: Adds the copied crop only to the single item being right-clicked.
  • Paste Crop to selected items: Adds the copied crop to all selected items.
Pastecrop.jpg

From the Preview Window

You can use the contextual menu in the Preview window to duplicate crops between images. To copy a crop, right-click on an image in the Preview Window and choose Crop > Copy Crop. Then in a different image, right-click im the image and select Crop > Paste Crop.

Prevcrop.jpg

Clearing Crops

When viewing a cropped image in the Preview Window, you can clear the crop by pressing Shift-c (Windows) or Option-c (OS X)

Crop Settings

For more options, click the Settings button in the Crop panel.

Crop Settings.jpg
  • Shield area checkbox controls whether the area outside of the crop is darkened. This helps you visualize what the actual crop will look like.
  • Show Grid overlay gives you a grid to help in straightening and composing the crop.
  • Show Crop center crosshair allows you to turn the center on or off as needed.
  • Crop Shape The crop area can be constrained in proportion. The numbers refer to proportions rather than units, i.e. a 3:2 proportion will keep the crop the same shape as a 35mm format image.

The crop will remain with the image and will be displayed in the normal Contact Sheet view so you can always see which images have crops set. When images are Saved As or Exported to HTML etc, the crop can be applied to the resulting image. In relevant dialog boxes there are Apply Crop check boxes so you can have the choice of cropping, or not, during that operation.

Click the Remove button to reset the image to its original state. Clicking Save will keep the settings on your clipboard and allow you to Paste the same crop settings on other images as long as the info is on your clipboard (.i.e. as long as you don't copy anything else). You can save Snapshots of constrained crop settings which can be a great time saver if you commonly use a number of standard crop ratios.

You can also access Crop tools via the contextual menu, usually accessed by right-clicking or ctrl-clicking on an image in the Preview Window. Copy/Paste/Clear Rotation/Remove/Make Unconstrained and Settings are all accessible from the Crop submenu.

Zoom Panel

Keyboard Shortcut
Toggle Zoom
Z
Zoom in
+
Zoom out
-
Lock
L
Zoom detail
(Mac) ⌘-click in the photo
(PC) Ctrl-click
Pan
Opt-arrow keys
Fast Pan
Opt-Shift-arrow keys
Toggle display of blown highlights
B
Toggle display of blocked shadows
N

Checking the Zoom checkbox applies whatever zoom setting has been chosen on the zoom slider bar. (For example, illustrated below, the zoom is set to 2x or 200%.) The Zoom slider has increments from 25% to 800% but the most useful ones are 100% and 50% for checking critical sharpness when editing.

Scroll down in the Info panel to see the Zoom slider

The Hand tool is active when the mouse is over the image - left-click/drag to move the image around. Also, use the Option-arrow keys to move the image or the Option-Shift-arrow keys to move it in bigger steps.

The mouse wheel can also be set in Preferences to Zoom or bring up next image.

Lock Scrolling is used when viewing two zoomed-in images in either of the comparison modes. Checking this box locks the two images together when moving either one with the hand tool. This is useful for very close comparison of two similar images when you need to examine the same part of both images in great detail. Lock Scrolling also zooms both images in sync. To use this function, set the Preview window to one of its compare modes (horizontal or vertical) then zoom in and align your images to show similar details. Then enable the Lock Scrolling function by either clicking on the ‘Lock scrolling’ checkbox or by pressing the ‘L’ key. Now both images will pan around together when you drag either of them around with the mouse or by using the Option-arrow keys.

If you ⌘-click on a particular detail of the image in the Preview window it will zoom to whatever percent size is currently set on the slider, centered on the spot you clicked on. ⌘-click again will zoom back out.

Histogram

Found at the bottom of the scrolling Info panel of the Preview window

Displays the Histogram information for the image which is currently displayed/ highlighted in the preview window.

All three RGB colors are shown overlaying each other and where they overlap the composite color is shown. White is the region where all three colors overlap, yellow for red and green, cyan for blue and green and magenta for red and blue.

Highlights & Shadows

Use these controls to highlight areas on the image in the Preview window where the highlights or shadows have no detail. It is off by default. You can also turn these on and off using the 'N' (shadows) and 'B' (highlights) keyboard shortcuts.

Thumb Gallery

A Note about the thumbnails displayed as a filmstrip at the bottom of the Preview window: This section of the screen gets its background and highlighted colors from the Preferences used for Contact Sheets - see Here for details. The ‘Set’ color shows which of the thumbs displayed in the Preview filmstrip is the one currently highlighted in the Contact Sheet view. (By default, it's light yellow)

To the left of the Film Strip are two gadgets - ‘All’ and ‘Selected’. If you have a multiple selection active in the Contact Sheet View, using the Selected tab here will restrict the Preview window to showing only those images. The Arrow keys will step through only the Selected images. Using the All tab will then include all images in the Contact Sheet View whether selected or not.

Preview filmstrip.jpg

Video Files

Video files can be viewed and even played in the Preview window (Mac Only). You can choose which frame of the video file is used as the preview thumbnail by navigating to the desired frame with the video playback controls, then Ctrl-clicking on the video and selecting "Set as Poster Frame." You can save the current video frame by selecting File > Save Photo As. If you select a poster frame for a video, that is the photo that will be saved if you select multiple video thumbnails and then saving.

Video Frames.jpg