Selection Tags and Color Classes

From CameraBits
Jump to: navigation, search

Selecting Images

In the Contact Sheet window simply click once on a thumbnail to select it. Notice that the background changes color when you do this. In Preferences you can customize this to pick a background color that you can quickly recognize. A good combination to use is light grey for unselected, with black text and dark grey or black with white text for selected images. The important thing is to be able to tell at a glance which images are selected or not.

To select multiple images together, hold down the ⌘ key and click another image. Holding down the Shift key selects images between your first selected image and a new selected image. Images can be removed from a selection by clicking on them again while holding down the ⌘ key. To clear the selection simply click on another image, outside the images completely or ⌘D to Deselect All.

(The effect of the Shift and ⌘ modifier keys can be swapped in Preferences)

Tagging

A Tagged image is one which has the small checkbox ticked in the lower right of the thumbnail. Tagging is distinct from Color Class as it is an on/off facility and can be used in parallel with the Color Classes to allow a huge variety of editing and categorizing strategies.

Keyboard Shortcut
Tag Selection

Mac: ⌘+
Windows: Ctrl+

Untag selection
Mac: ⌘-
Windows: Ctrl-

To Tag an image simply click in the check box or, with a selection of images,⌘+ Tags and ⌘- Untags. For a single image T will toggle the tag.

⌘T selects all tagged images. F3 will filter the view to show Tagged Images only.

Modifier-click on the Tag box in a selection of images to Tag or Untag the whole selection.

Tagcheck.jpg

Color Classes

One of the fundamental features in Photo Mechanic is the ability to mark images with 8 different color classes plus ‘None’. This allows an Editor to make subtle distinctions between image groups based on whatever criteria are deemed necessary. For example, a photographer might like to divide images up into ‘Top Shots’, ‘Keepers’, ‘Not Sure’ and ‘Oh dear!’. Like everything in Photo Mechanic, Color Classes are fully customizable in Preferences and so you could use Classes like these if you choose. The Defaults are Winner, Winner Alt, Superior etc but there is no reason why you cannot use your own Classes, and colors if you like. You can even chose your own color scheme by clicking on the color swatch in the Preferences screen and picking a new color for each. Important Note: If you also work with Adobe Lightroom and want to be able to set Color Classes that show up in LR, please see this note on compatibility settings: Maximizing IPTC/XMP Compatibility

Color class descriptions in Preferences > General


To use the Color Classes simply hit a number key when you have a single image selected and a bar beneath the thumbnail will change to the appropriate color. If you want to set a color class for a multiple selection, just hold the ⌘ key down when you hit the number key.

If you click on the color bar under a thumbnail the Color Classes list will appear for yet another way to set the Color Class. To apply a Color Class to a selection, use the Modifier key when making the change and the new class will apply to the whole set.

See Slide Show for another way to use Color Classes.

Color Class Widget

The Color Class Widget

The Color Class Widget can be seen at the bottom right of the Contact Sheet window. To use it make sure the check box is ticked and then click on a color box to either display or hide images of that particular color class. The last box on the right toggles on and off those images with no set color class. You can click-drag the mouse pointer across all the boxes to check or uncheck the colored squares.

Using this widget, together with tagging, gives you a huge variety of ways of sorting out your images to suit your own personal style of working. Along with Star Ratings, Color Classes are also compatible with Adobe Bridge and Lightroom.

By turning on only the green Class in the Color Class Widget, only images with that Color Class will be shown, as seen below.

Coloclasses.jpg

Modifier-click on a Color to show only that Color and again to turn all colors on again. Modifier-click on an off color to turn that color on and the other colors off. You can even choose to show only those images that have no Color Class set.

Drag your cursor over the widget to toggle the colors on and off.

To remove all filtering and show all images choose View All from the View menu or press F1. ⌘-Ctrl-F1 through ⌘-Ctrl-F9 will also filter the Color Classes.

To set a Color Class display default, set the Widget to display the Classes you want, right-click on the Widget and select Set as Default. Later you can reset the Widget to the new default by right-clicking and choosing Restore to Default.

Star Rating Widget

Star Ratings work in much the same way as Color Classes, and the combination of the two allows for quite sophisticated ranking and sorting. One benefit of Star Rating is that it can be read by other applications so a ‘rated’ folder of images can be viewed in other apps with the Star Ratings still intact.

The star widget is right next to the color class widget

To set a Rating on a selected image or group of images in the Contact Sheet view use Ctrl-1 to 5 (on OSX) or Alt-1 to 5 (on Windows) to set the number of stars. On individual thumbnails click the Star Rating you want or drag the mouse over the stars to increase or decrease the rating.

To display differently rated images you can use the Star Rating Widget to the left of the Color Class Widget and it operates in all the same way as the Color Class widget. This filters Star Rated images but does not select them.

To actually select certain Star Ratings,⌘-Option-3, for example, will select all images currently displayed in the contact sheet with a Star Rating of 3.

To use the mouse to display certain Ratings just click on the Star/Number you wish to show. You can have any, all or some Ratings displayed, shown by dark or light Star/Numbers. You can drag the mouse over the Stars to include more ratings.

To set a default, set the Widget to display the Rating that you want, and right-click on the Widget and select Set as Default. Later you can reset the Widget to the new default by right-clicking and choosing Restore to Default.

The check box to the left of each Widget disables the effects of that Widget, showing all images in the contact sheet.

Note that the Widgets operate on the current Contact Sheet of displayed images, not necessarily the entire folder. In other words if you have set the Color Class Widget to show only thumbnails with a Red label, the Star Rating Widget will then sort Star Rated images within this Red subset.

External Compatibility

Both Color Classes and Star Ratings can be recognized by certain other applications such as Adobe® Photoshop Lightroom® and Adobe Bridge®. Star Ratings can also be exchanged with Microsoft® Expression Media®.

Color Classes will be recognized by apps if the text label for each class is exactly the same in each app. You can edit the default Photo Mechanic labels in Preferences/ General. It doesn’t matter what the Color Classes are labelled, just that the labels must be the same in all apps.


It is also a good idea to edit the actual colors themselves to give consistency throughout the various apps. Lightroom and Adobe Bridge use the same color sets and these cannot be directly edited, only the labels. Photo Mechanic allows editing of the colors so it makes sense to make sure it is set to the Adobe default of red, yellow, green blue and purple.

This is how the General Preferences might be set in Photo Mechanic:

The General Preferences screen
  • Adobe Bridge: Color Class labels can be edited in Preferences/Labels, and there are only 5 to use. These will correspond to the Color Classes in Photo Mechanic which have the exact same text labels. The other three will not show up in Bridge and can be used for Photo Mechanic-specific sorting and editing.
  • Lightroom: Five Color Class labels can be edited in the “Library” mode under Metadata/Color Label Set/Edit. Type in new labels and click ‘Change’ to lock in the new labels.

For Color Classes and Ratings to show up in other applications, Lightroom must be set to write metadata changes to the original files automatically - to set this option look under Metadata / Save Metadata, or to do it automatically, look in File/Catalog Settings and check the ‘Automatically write changes into XMP’ checkbox.

You must also use XMP sidecar files with your RAW files when working with Adobe products. Click here to see the best Adobe-compatible IPTC4XMP settings.

  • Microsoft Expression Media: Star Ratings work fine, and color labels will work properly if you set the ‘Synchronize Color Class with IPTC/XMP Urgency field’ checkbox.

Remember to Synch the new ratings (Action/Synch Annotations) back to the original files after you have made changes otherwise the new Color Classes and Star Ratings will not be read by other apps since they initially only exist in the Expression Media database. Expression Media does not write metadata to the original files unless told to.

  • Capture NX2 (Nikon): Star Ratings work fine, and color labels will work properly if you set the ‘Synchronize Color Class with IPTC/XMP Urgency field’ checkbox. You must also embed IPTC4XMP in your TIFF-based RAW files (NEFs.)

Sorting

Much of the sorting that can be done in Photo Mechanic is done using Star Ratings, Color Classes and Tags, these are explained in detail in the Selections section.

Photographers are used to spreading transparencies on a light box and gradually dividing them up into sets such as ‘Keepers’, ‘Not Sure’ and ‘Wastebin’. Photo Mechanic uses a more sophisticated version of much the same method by assigning images with a Color Class to designate its worthiness. Classes can be set individually or en masse and each Class can be displayed on its own, or with any other Classes. In fact the number of ways in which the images can be sorted and displayed is really only limited by your own imagination and workflow requirements.

Tagging is a simple way of sorting your images, they are either tagged or not. You can display all tagged images, all untagged images or all of them together. For a quick edit simply click the tag box on all the images you like and then hit F3 to display Tagged Only. At this point you might choose to Select All (⌘A) and FTP (⌘U) the whole set as small preview JPEGs to a client.

Other tools for Sorting include the “Sort by” menu on the Contact Sheet Toolbar.

There are presets to sort by, plus a custom option which allows sorting by any variable, and even by a secondary criteria. This means you could display the files by file type, file size, even by ISO setting.

A note on Sorting and Filtering

The tag is part of each image's metadata that needs to be read from the file and performing this reading takes time. Photo Mechanic can get the data it needs from the files on a fast local drive on the order of a hundred images per second. If it is on a network drive, it can drop as low as tens per second. Photo Mechanic generally is set to not filter on anything at all and as such it can get directly on to the business of showing you your images. But in order to filter and only show the tagged images, Photo Mechanic must get the metadata for all of the images before it can filter out the non-tagged images. If Photo Mechanic has already read the metadata on all of the images, then the filter will happen in mere seconds. But if it hasn't read all of the metadata yet, then it must read it all and depending on how fast Photo Mechanic can access that data, the filter can take a long time. In your case this filtering is taking minutes.

For example: With 15,000 images, even at 100 images read per second, it will take 150 seconds (2.5 minutes) to begin the filtering process. If Photo Mechanic is only able to read the metadata on 10 images per second then it would take 25 minutes to begin the filtering process.

Photo Mechanic does read all of the metadata in the background while you browse your images, but if it hasn't read it all then it can take a long time to do any kind of filtering. The Sort Cache which was introduced in Photo Mechanic 5 does help with this task, but the Sort Cache is of no use if the metadata hasn't been read fully at least once prior to the sorting/filtering. If images have changed since the sort data was cached, then it must be re-read to make certain that the sort data isn't stale. If your images don't change often, then the Sort Cache can be quite beneficial.

Set sort order from the main menubar

Finding

Keyboard Shortcut
Find
Mac: ⌘-F
Windows: Ctrl-F

Sorting and Finding are two sides of the same coin in that they both allow the user to make selections and view images based on certain criteria. Photo Mechanic allows two types of filtering: Sorting with Color Classes, Star Ratings and Tags, plus Find.

Menu find.jpg

The Find command in the Edit menu allows searches to be made based on any information contained in the file, be it the file name or part of the file name, as well as any IPTC data encoded in the file itself. For example you could filter your images based on the Category contained in the IPTC data of your files (which you might have set during Ingest). The ‘Find’ results become the active selection in the Contact Sheet, which you could then Tag or Class as needed.

Type in the string you wish to search for, paying special attention to case and spelling.

Use the ‘Find:’ popup menu to choose how your search term(s) are handled. There two choices: ‘Any of the words’ and ‘All of the words’. Use any of the words when you want to enter multiple terms and you don’t care if an image contains all of the words. Use all of the words when you want to find photos that contain all of the words you’ve entered.

Use the ‘In:’ popup menu to choose what the Find panel is allowed to search. If you just want to narrow your selection, set the popup menu to ‘Selected photos’. If you want to create a new selection from the entire Contact Sheet, set the popup menu to ‘All photos’.

Use the two checkboxes following the ‘Searching:’ text to choose what metadata you wish to consider. Use the ‘Case sensitive search’ checkbox to make your matches more exact.

Use the ‘Show/Hide IPTC’button to show or hide the dozens of IPTC-related checkboxes. If you’ve got them setup the way you want them then hiding them will make the panel much smaller, allowing you to see more of your results.

Set individual IPTC checkboxes to choose what fields you do or do not wish to search. Only checked items will be searched. Use the ‘All’ button to quickly set all IPTC checkboxes on. Use the ‘None’ button to quickly clear the IPTC checkboxes.

Finally click on the ‘Find’ button to begin the find operation. The progress bar to the left of the Find button lets you know how far along the find operation is. Once complete, the photos that end up selected will have met your Find criteria.

If you end up doing a lot of the same find operations repeatedly, use the Snapshot button to the left of the progress bar to save and restore your Find criteria.

See Find/Replace for details on finding and replacing data. See Spotlight Search for details on how to search outside of a Contact Sheet for images with specific criteria.

Arrangements

Contact Sheet thumbs may be arranged in any arbitrary sequence you choose simply by dragging them around the screen. This brings computer software closer to the ‘lightbox’ paradigm whereby you can sort your images as though they were transparencies on an actual lightbox.

Arrangements can even be made across multiple folders if the folders are open in the same contact sheet.

Arrangements can be saved with the folder(s) simply by dragging thumbnails into new positions. Each time this is done the Arrangement will be saved. The Sort popup menu in the tool bar will now update to ‘Arrangement’ so that the particular order that you have arranged the images can be retrieved. This holds for multiple folders opened into one contact sheet. It's best to use the Remember Folders command on the File menu to save the folders’ combination as a ‘Favorite’ for later use.

In the Contact Sheet tab of the Preferences dialog there is an option to set whether you have to be in an ‘Arrangement’ Sort to be able to move the images around.

Special tip: You can quickly move to the beginning or end of a Contact Sheet by using the Home and End keyboard keys. On many Mac keyboards, these are achieved by pressing the Fn key plus Left or Right cursor keys