Preferences

From CameraBits
Jump to: navigation, search
Keyboard Shortcut
Preferences

Mac: ⌘-,
Windows: Ctrl-,
(comma)

There are many parameters that can be set in Photo Mechanic to customize its operation to the way you choose to work. In the Preferences Dialog box there are a series of tabs across the top, each of which leads to a new set of preferences.

General Preferences

PM Preferences.jpg

On startup: This is how you would like Photo Mechanic to behave when it is launched.

On mount of Camera Disk: This is what action you would like to happen when Photo Mechanic senses that a card has been placed in a card reader. The logical choice here is the second one, ‘Show Ingest Dialog’, but you can also ignore it or cause the card to be browsed as a set of Contact Sheets.

Color Classes: Here you can customize the Color Classes and names that Photo Mechanic uses to sort images. Click on a color box to choose another color and type in the box next to it to re-label that color. If you wanted to maximize compatibility with Adobe® Bridge®/Lightroom® you would set the labels and colors here to match the labels and colors you use in those applications. Additionally, the Synchronize Color Class with IPTC/XMP Urgency field check box, when set, will cause the IPTC Urgency field to be set as the Color Class index whenever the Color Class is adjusted.

GPS: This section allows you to choose how you want GPS information displayed. The GPS Latitude/Longitude format popup menu lets you choose the format for display of GPS coordinates. The Units for GPS distance popup allows you to choose miles or kilometers for distance displays.

Contact Sheet Preferences

PM contactsheet.jpg

Selection Method: Three options on how a selection may be made. Option one is the default and is the one most people will be familiar with.

Default Sorting Method: This is the sorting sequence that Photo Mechanic uses to display a Contact Sheet when the sheet is first created. This will appear in the main menu bar in the Contact Sheet window and can be changed.

Behavior, Wrap-around: Toggles whether the arrow keys progress from the last image in a Contact Sheet back to the first image when the end of a folder is encountered.

Behavior, Close Contact Sheet window when last tab is closed: When this is enabled, closing all the tabs in the Contact Sheet window will also close the window itself.

Behavior, Create New...: If there are no Contact Sheets open and Photo Mechanic is minimised, a new blank Contact Sheet will be created when photo Mechanic is resumed.

Only Allow Arrangements...: Thumbs can only be dragged to make new arrangements when the Sort dropdown is set to Arrangement.

Automatically rescan when folder contents change: Causes Contact Sheets to rescan when other applications notify the system that they have added or removed files from a folder. This feature has been a source of reliability issues for some users and has been made optional. If you are having issues when working with folders outside of Photo Mechanic, please try turning this option off. The change will only take effect when Photo Mechanic is restarted.

Thumbnail section:

Default Size: This is the size of thumbnail that Photo Mechanic uses when it first creates a new Contact Sheet. It can be changed by using the thumb size slider on the Toolbar.

Generate High Quality Thumbnails: Turning this off displays the very small EXIF thumbnails only. Super-fast but low quality.

Sharpen Thumbnails: Thumbnails will have sharpening applied and will look crisper to the eye, again, at a slight cost in speed.

Combine RAW+JPEG into single thumbnail: Toggles the combination of RAW+JPEG pairs into a single thumbnail.

Show Soft Rotation indicator on thumbnails: Displays a symbol to show if a thumbnail has been rotated. Also allows other indicators like Upload status to be shown.

Softrotate.jpg

High DPI Display Quality: Change this setting if you have a high resolution display (e.g. Retina or 4K or above). Setting this to “Best (uses more memory)” will ensure your thumbnails will display at the best resolution possible.

Labels: Sets the number of lines that are used beneath each thumbnail to show variables. Here one line is used as default to show file name. You can choose File Name plus 1 to 3 more lines, each of which can display variables such as Caption, File Size, etc.

Scroll Wheel Sensitivity: Controls the amount that the mouse scroll wheel, if available, moves the screen while viewing the Contact Sheet. (There is a separate sensitivity setting for the Preview window.)

Colors Section:

Colors: Use these options to set how you want Photo Mechanic to appear. A good set of colors has good contrast between the unselected thumbs and the selected ones, with good text contrast for both.

Contactsheetcolors.jpg

Files Preferences

PM files.jpg

Move Photos to Trash: Check this box to move deleted items to the Trash. Unchecking this box deletes the item permanently.

Play move to Trash sound: Photo Mechanic will play a sound effect when deleting photos. Uncheck this to silence this effect.

Never Warn when deleting: Turns off the warning when deleting files. Use with caution.

Allow modification of files on Camera Disks ( not recommended ! ): By default, Photo Mechanic will not make any changes to files on a memory device so that if anything ever goes wrong, you'll still have your original untouched files. If you're really, really sure you want to turn off this protection, you can.

Update Creation Time: Changes the creation time of the image to the EXIF time of capture during Ingest or Copy. Unchecking this option will cause the files to have a creation time set as the time of Ingest or Copy, not the actual time of capture.

File Extensions: Choose upper or lower case for file extensions. Once set this is best left alone for consistency. Lower case is safer than upper case for web use.

Resolution Units: Choose between pixels per centimeter or pixels per inch. PPI is the default.

Add Photoshop resolution info to Camera JPEGs during IPTC update: Sets the default resolution for files created during Copy or IPTC Updates for other imaging applications which use a dpi value for sizing.

Default Resolution to use: Choose a resolution to use for all file operations such as Resize, Crop, Save As, FTP etc. Saved images will have this resolution when viewed in other applications.

Renaming resolution: Set options for what Photo Mechanic should do when it tries to save a file to a folder and there is an identically named file already present at the destination. This policy applies to all renaming operations. You can choose to append a letter, or a single or double digit number, when needed. The best option here is probably ‘Append Digits when needed (01,02 etc.)’. This option makes it easy to see at a glance when there were two files with the same name since the new file name will be longer and easy to spot.

Always update XMP Label when changing Color Class: Tells Photo Mechanic to set the XMP Label to the new Color Class name even if the XMP Label didn’t previously match the Color Class name.

Location of User Templates: These settings allow you to choose a folder where your custom templates are stored on your system. The Export dialog, HTML Template Exporter, and Uploader dialog will look here for additional templates.

The Windows version of Photo Mechanic includes a button to set HTTP proxy settings for templates that use HTTP as the basis for their protocol. (The OS X version of Photo Mechanic picks up the HTTP proxy settings from the System Preferences Network pane.)

Proxyhttp.jpg

RAW Preferences (Mac)

RAW Rendering is part of Mac OS X. Photo Mechanic cannot render images on Windows.

PM raw.jpg

Enable RAW Rendering: turns on the facilty to use the OS RAW rendering capabilities.

For RAW+JPEG: If there is an image pair when you have shot with the camera in RAW+JPEG mode then you can choose to work with the JPEG for speed or render the RAW for quality.

For RAW Only: You can choose to use the embedded JPEG preview in the RAW file to speed up thumbnailing or export, or use RAW Rendering to generate the output. Using embedded previews is faster but using RAW rending can produce higher quality results.

Launching Preferences

These are preferences for how Photo Mechanic launches other applications in your workflow.

PM launching.jpg

Configure Image Capture: (Mac only) Use this option to set up Photo Mechanic to automatically launch when a camera card is mounted. Used in conjunction with Preferences/General to bring up an Ingest Dialog on launch. On Windows, “AutoPlay” is used to launch Photo Mechanic when a camera card is mounted.

Default application to edit photos: Choose an external editor to launch when the Edit photos options are invoked. For many people this will be Adobe Photoshop but you can choose whatever you like here.

Default application to edit movies: same as above but for movie files.

Assign Specific Application to File Type: Click ‘Set...’ to assign different file formats to different applications. You might like to use Photoshop as the default but also set ImageReady to open GIFs and a particular RAW Converter to process NEF files. These options are shown when using the right-click context menu option on photos in the contact sheet: ‘Edit Photos with’. You can also use "Custom Editor" slots to be able to assign External editors as options that appear when you select 'Edit photos with..." from the menu.

Max Photos to Edit: Sending more than this number of image to an external editor will bring up a warning. This warning acts as a safety net in case you send more files than your computer can handle at once. The number of files you can safely send will depend on both the file size and the amount of RAM available.

RAW+JPEG Editing: When Photo Mechanic is treating a RAW+JPEG pair as a single file, this option sets which one of the pair is sent to an external editor when using the ‘Edit Photos’ command. You can toggle this preference temporarily by holding down the Modifier key when choosing to edit.

Opening Contact Sheet with Navigator or Favorites panes: Sets one of four options for single-clicking or double-clicking in the Navigator or Favorites panes.

The “When opening a new Contact Sheet make the Navigator show the path to the folder” checkbox can be set so that the Navigator shows the full path to the newly opened folder.

Photoshop Droplets: Use this to set where your Droplets are stored so Photo Mechanic can load them into the ‘Send Photos to Droplet’ menu option on the Image menu.

IPTC/XMP Preferences

PM iptc.jpg

The IPTC / XMP Preferences section is where you setup how Photo Mechanic reads and writes IPTC and/or XMP metadata with photos in order to customize your workflow with other applications that use this metadata. Most IPTC metadata fields (e.g. City, Photographer, etc.) have an equivalent field representation in XMP (known as IPTC4XMP), although XMP can also contain other metadata such as rendering preferences. Unfortunately, not all applications or operating systems support IPTC and XMP metadata equivalently, so Photo Mechanic has been designed to be very flexible about how IPTC and XMP metadata is both read and written.

For example, since IPTC (an international standard) was in use for more than a decade before XMP (a format introduced by Adobe Systems), older applications may only handle IPTC data and not be able to view or edit XMP data. Newer and future applications may only handle XMP. Some applications that handle XMP may expect the metadata to be embedded within photos such as JPEGs and TIFFs, but expect to find an XMP sidecar file for RAW photos. Some applications may be able to read, but not write, IPTC or XMP metadata embedded within a RAW photo. If a photo contains both IPTC and XMP metadata, some applications may read the IPTC and ignore the XMP or vice versa.

By understanding how all your various applications handle IPTC and/or XMP metadata, you can configure Photo Mechanic to read and write this metadata for maximum inter-operability. The handling of proprietary RAW photos, for example, can be very different than the handling of standard JPEG, TIFF, and PSD photos. Unlike the standard photo formats, which have well-documented methods for embedding IPTC and XMP metadata, most proprietary RAW photos do not come with IPTC or XMP metadata; and if they do, are difficult to edit because of their TIFF-based structure (and if altered may fail to work with certain applications or operating systems). Therefore, some applications favor using an XMP sidecar file for RAW photos. Fortunately, Photo Mechanic is able to read and write both IPTC and XMP in various combinations depending on the photo’s format.

In the left section, When reading IPTC/XMP, you tell Photo Mechanic how to handle the reading of IPTC/XMP data when both types of metadata are present. For example, if you create a JPEG with both IPTC and XMP (e.g. by saving from Photoshop CS), then edit the photo’s metadata with an older application that only understands IPTC, then the XMP metadata in the file will be “stale” (out of date). Therefore, in this case, you will want to have Photo Mechanic read IPTC before XMP for JPEG (and TIFF and PSD) photos. On the other hand, if you edit the same photo with a newer application that only uses XMP, then the IPTC metadata will be stale and you will want to change the JPEG read preference to read XMP before IPTC. For RAW photos, there is an additional third place to find metadata: the XMP sidecar file. Therefore, you can choose the first, second, and third choices for reading IPTC/XMP metadata for RAW photos. If you are using a Mac, you can also choose to read the IPTC from a photo’s “resource fork”, either as the first place to look or only as a last resort or uncheck it to ignore the resource fork altogether.

In the right section, When writing IPTC/XMP, you tell Photo Mechanic how to handle the writing of IPTC/XMPdata. ForJPEG,TIFF,and PSD photos,you can choose to embed IPTC or XMP or both. By default, Photo Mechanic will embed both IPTC and XMP into these standard formats, but you may want to only embed IPTC for older applications or only XMP for newer applications. For TIFF-based RAW photos (e.g. 1D TIF, NEF, CR2, ORF), you can choose to embed IPTC or XMP or both. If you choose to embed neither, or for non-TIFF based RAW photos, Photo Mechanic will always create and/or update an XMP sidecar file. However, if you embed IPTC and/or XMP in a TIFF-based RAW photo, then the XMP sidecar is optional and you have three choices of how to handle them. You can always update the XMP sidecar file, or only if an XMP sidecar file is present, or only if an XMP sidecar file is present AND already contains IPTC4XMP metadata. On the Mac, you can also choose to add the IPTC-NAA resource fork when embedding IPTC/XMP.

The option Don’t update embedded IPTC/IPTC4XMP even if it exists... causes Photo Mechanic to only update the XMP sidecar file, letting any current embedded IPTC or XMP data stay in its current state.

One important note: the IPTC/XMP write preferences have to do with ADDING IPTC/XMP metadata when it doesn’t exist in a photo. Photo Mechanic will always update any existing metadata to make sure no metadata is left stale (unless you force Photo Mechanic not to update it with the previous option.) For example, if you choose to ADD only XMP metadata into JPEG photos, but Photo Mechanic finds only existing IPTC metadata in a JPEG, it will update the IPTC data AND add XMP data to the JPEG photo.

Also, Photo Mechanic will load an IPTC ANPA 10000 resource if it exists as a last resort if no embedded IPTC or XMP or XMP sidecar is available.

IPTC Line Endings: Sets the Line Endings that are used in the IPTC data. The IPTC standard does not specify a line ending (a character that lets a computer know to start a new line) and the original Mac version always wrote out a CR character (carriage return). Windows uses CR/LF (a carriage return followed by a line feed) to delineate new lines. This option lets you choose how you want it to work.

When viewing photos in RAW+JPEG mode use the metadata from the: This popup menu allows you to choose where the metadata comes from when RAW and JPEG images are paired.

For JPEGs with multiple IPTC and/or XMP records: Some applications edit IPTC and XMP metadata in JPEG photos in different ways. If Photo Mechanic encounters improperly formatted JPEG photos with multiple records, this lets you configure what Photo Mechanic will do when it encounters this situation. You can choose to Read/update the first IPTC or XMP record or the last record.

Use a (comma or semi-colon) to separate repeating fields (Keywords, Caption Writers, etc.): Lets you choose how repeating IPTC fields are separated. If you like to use commas in names as in “Last name, First name” then choose semi-colon as your separator.

Check Spelling: Checks spelling of the Caption field using the system Dictionary.

When updating XMP, add Structured Keywords to hierarchical keywords field only: When unchecked, the Structured Keywords will be added as a flat list to the keywords field. Checking this box will attempt to ensure that the keywords remain hierarchical within the XMP file.

Always Use Today’s Date in Stationery Pad: Presets the Date field in the IPTC Stationery Pad to the current system date. You can override this in the IPTC Stationery Pad if you want, it just opens with the date already set to ‘now’.

Restore defaults: Restores all IPTC/XMP ‘factory’ defaults.

Maximizing IPTC/XMP Compatibility

Having data move smoothly between Photo Mechanic and other photography software is very important. To make sure your key metadata follows your photos as you work with them in other programs, you may have to adjust the settings in Photo Mechanic. Other software can look for metadata in different places, so you'll have to specify where and how to keep it.

You can now select a specific group of settings designed to work best with other common software packages. Do this from the "Snapshot" button in the lower right:

SnapshotIPTCb.jpg


Adobe settings

The following settings will maximize compatibility with Adobe products. The key is to remember when working with Raw files that Adobe will try to look for metadata in XMP sidecar files that live alongside each Raw file. If you click the "Restore defaults" button, you should get these settings which will work well with Adobe products.

PM iptc adobe.jpg

In order to be able to set Color Classes in Photo Mechanic that will be visible in Adobe Lightroom, change your labels to match these settings. Spelling of the text labels is important. You can change them in Photo Mechanic by clicking in the Preferences window.

Color class prefsadobe.jpg

Capture NX2 settings

Here are suggested settings for working with Nikon Capture NX2:

Nx2 iptc new.jpg

The key difference here is that (as of February 2013) Capture NX2 doesn't make use of XMP sidecar files, so tell Photo Mechanic to look for embedded XMP first.

Note on Default IPTC Encoding: Users should either use the default Mac Roman encoding which is historically the default encoding that Photo Mechanic has always used, or they should change it to one of the other encodings to work with the encoding of choice used by their organization. For better compatibility with non-PM users on Windows, using “Microsoft Latin1+Euro” is a good choice. Using “Write IPTC as Unicode” makes IPTC fully international, but unfortunately some applications do not know how to interpret Unicode IPTC data even though they work fine with Unicode XMP data.

Preview Preferences

PM preview.jpg

Enlarge photos to fit previews and slide shows: Check this box to have Photo Mechanic enlarge images that are smaller than the preview window and the slide show window. Images will be resized to fit within the workspace. Images that are bigger than the workspace will always be reduced to fit unless zoom is used.

Wrap-around: Allows the arrow keys to progress from the last image to the first image or the first image to the last.

Show Soft-rotation: Displays a small rotation icon to designate that an image has been soft-rotated from its original orientation. Photo Mechanic does not alter original image data, it merely displays a preview as opposed to actually rotating the original image. This indicator will let you know when an image has been soft-rotated.

Auto-center thumbnails in thumbnail gallery: Causes the current selected preview to have its thumbnail centered in the thumbnail gallery.

Sharpen Previews: Displays Previews with sharpening applied for a crisper view, at a slight cost in processing speed.

High DPI Display Quality: Change this setting if you have a high resolution display (e.g. Retina or 4K or above). Setting this to “Best (uses more memory)” will ensure your previews will display at the best resolution possible. Please note that when set to "Best," the preview will use more memory than in "Standard." If your performance changes, consider adjusting your Memory Cache setting down to 256MB to compensate. (This is set in Caching preferences)

Automatically advance to next photo: When the “Tag is changed”, “Color Class is changed”, or “Rating is changed” checkboxes are checked these options will cause the preview to advance to the next photo when any of the checked options are changed.

When zoomed, the mouse wheel: Allows the mouse wheel to function in one of two ways when zoomed-- the mouse wheel can pan the preview around, or it can advance to next/previous photo. (Mac OS X-only feature.)

Mouse wheel sensitivity: This is where you can adjust the sensitivity of your mouse wheel for panning and advancing. (This is a separate setting from the "Scroll wheel sensitivity" setting for working in the Contact Sheet)

Cropping: Sets the default mode of Cropping, either constrained or freehand. If you choose constrained you can set the default ratio here. The numbers represent aspect ratios not units. For example, 5:5 will give a square crop and 9:3 will give a panoramic one.

Edit/Preview: Sets whether a double-click on a Contact Sheet thumbnail Previews or Edits the image. Edits will be done in the default Editor set in Preferences/ Launching.

Background Colors: Choose colors for the background of the preview window.

Caching Preferences

Location for Cache: Choose a folder where you would like Photo Mechanic to store cached thumbnails. Note that if you choose a location other than the default and are using OS X then you need to tell Spotlight to ignore your cache folder or performance will be reduced.

Disk Cache Size: Maximum size of the cache folder. Generally, bigger is not always better, and the usefulness of the cache will top out at a few thousand MB, because startup and shutdown times will become excessive.

Reserve at least: Makes sure that there is always this amount of space left on the cache disk volume.

Empty on Quit: Empties the cache when Photo Mechanic is closed. Photo Mechanic is very quick to generate thumbnails and previews so it is not always necessary to keep the cache between sessions. On quit, if emptying the disk cache takes longer than one and a half seconds, then a progress dialog is displayed.

Remove Cached files that are older than: Cached files older than ‘n’ days old are removed as Photo Mechanic starts up. Keeping a large cache between sessions can cause Photo Mechanic to launch slower than normal because it has to check every cached file for its creation date on startup.

Memory Cache Size: Sets aside an amount of RAM to be used for caching and previewing. If you have less than 1GB of RAM this should be 64MB or 128MB, more if you are running Photo Mechanic on its own. For 2GB of RAM, 256MB would be a reasonable setting.

Sort Cache: Photo Mechanic can cache the sorting of large folders to improve performance when re-opening the folder later on. To save disk space, PM will clear out older cached data per your choice of size here. You can also "Empty Now" to immediately get rid of cached sorting data.

Color Management Preferences

PM colormgmt.jpg

Default ICC Profile: Sets a profile to use if a file has no profile assigned to it. sRGB would be the usual choice here since most non-ICC capable cameras would be using a nominal sRGB-like colorspace.

Color Manage Thumbs: Applies color management to the Contact Sheet view.

Color Manage Preview: Applies color management to the Preview.

Embed ICC Profile into Camera JPEGs during copy or ingest: Causes Photo Mechanic to embed the actual ICC profile into your images during copy or ingest operations.

Accessibility Preferences

PM access.jpg

Font scale for IPTC Caption field: Allows you to make the text larger in the Caption field of the new-layout IPTC dialogs.

Use Classic IPTC Dialogs: Sets Photo Mechanic to use the older IPTC Stationery Pad/IPTC Info layouts which many people are very familiar with.

Enable Save, Upload and Next button in IPTC Info: Uncheck this to prevent inadvertently saving over critical information while reviewing files.

Customize IPTC Info & Customize IPTC Stationery These dialogs allow you to control what fields appear in the IPTC Info and Stationery Pads, how those fields are shown in Photo Mechanic, and even how big the text fields is for data entry.

The Field column is the default IPTC name for the field and should generally be left alone. See here for a description of those fields: IPTC Variables Map

The Field Label column is the displayed description of the field in the IPTC dialog box. To change the way the field appears, double-click on the Field Label and change it to what you want. (E.g. Change "Description/Caption" to just "Caption" and then press Return or Tab to apply the changes.)

You can change the number of Rows of text input space.

Control which fields show up in your IPTC dialogs in the Visible column.


Single key shortcut for Color Class or 5-Star Rating: Set whether the number keys set the 5-Star Rating or the Color Class without a qualifier key when a single photo is selected.

Run Navigation Services dialogs in a separate process: When checked, this causes all Open/Save dialogs to be run in a separate process which makes Photo Mechanic run far more reliably, especially on Snow Leopard (10.6.x) Mac OS X systems. Unless you have a good reason to turn this feature off, please keep this feature on.

Show Growl notifications instead of modal alerts where possible: When checked, this feature causes certain modal alerts (for instance Ingest complete messages) to present themselves as Growl notifications. Growl lets Mac OS X applications unintrusively tell you when things happen. It is free software that you can install on your Mac OS X system. You can read more about it here: http://growl.info and download its installer.

Ask when quitting Photo Mechanic: When this is checked, Photo Mechanic will ask you if you're sure when quitting Photo Mechanic. This is most often useful if you are used to using keyboard shortcuts and accidentally use the shortcut to quit the program. If you have no contact sheet open, Photo Mechanic will not ask you if you are sure, even if this preference is enabled. Note: Enabling this preference may interfere with system shutdown on some computers as Photo Mechanic will not exit without confirmation.

Use lighter interface theme on dialogs and message boxes: Use this option if you require a change for readability.

AP Preferences

PM AP2b.jpg

Photo Mechanic has some special features to optimize use with the Associated Press

Exporting Preferences

Nearly all Photo Mechanic Preferences may be exported to a PMX file so that they can be imported into Photo Mechanic at a later time. If you run a second copy of Photo Mechanic on a laptop then this saves you having to set each Preference one at a time. Find the Import and Export buttons on the bottom of the Preferences window:

PM exort prefs.jpg

Importing Preferences

Choose a previously exported PMX file to import into Photo Mechanic.

Use the Merge settings checkbox to merge the imported settings with your current settings. If you want to replace your current settings with the imported settings, then turn off the Merge settings checkbox Not all settings can be merged, but many can.

Resetting Preferences

If for some reason you need to start over with your Preferences, you can completely reset them all to factory defaults. In rare cases this can even solve persistant crashing issues that come from corrupt preferences file. The process is different on OSX and Windows. Here's how you do it on each:

On OSX (Mac)

Resetting Photo Mechanic's Preference files will erase all of the entries in the Favorites pane and Open Recent list. If you need to restore your Favorites entries, then Take a screen shot of them before resetting PM's preference files.

If you have FTP connection settings or IPTC field lists that need to be preserved, then go to the Photo Mechanic Preferences dialog and click the Export button to save the current settings as a .PMX file. Call the file PM-old-prefs.PMX and save it wherever you like. Now quit Photo Mechanic. Use the Command-Tab shortcut when the Finder is running to show a list of all of the running application icons. If Photo Mechanic is not listed, then we can continue.

The Photo Mechanic preferences files are located in your user Library folder -> Preferences folder. Unfortunately this folder is hidden on the new Mac operating systems (Lion and Mountain Lion). We can get around that problem: with the Finder running click the Desktop so the Finder is active. Hold down the Option key and click the Go menu. Keep the Option key down so you can access the Library folder from the Go menu. When the Library folder opens, you can drag the Library folder icon from the top of the Finder window, to the left sidebar next to the Desktop entry. Make sure you see the separating line between two entries in the sidebar before letting go of the mouse. This will add the Library folder shortcut to the sidebar.

Now open the Preferences folder. Look for a folder called com.camerabits.PhotoMechanic. Rename this folder by adding -old to the name. If there are any com.camerabits.PhotoMechanic.plist files, then you can delete them or add "-old" to their names. There could be 3 of these plus 3 copies ending with Lockfile. Close the Finder window.

Start Photo Mechanic. If you see any messages about registration, you can re-enter it there, If you do not have your registration info handy, then quit Photo Mechanic. Go back to the Library folder and then the Preferences folder. ( Library folder shortcut will be in the left sidebar of any Finder window ).

Photo Mechanic should have created a new com.camerabits.PhotoMechanic folder. Open the com.camerabits.PhotoMechanic-old folder and move the com.camerabits.PhotoMechanic.registration file to the new com.camerabits.PhotoMechanic folder.

Now Photo Mechanic should be reset so it looks as if it has just been installed for the first time. Try the same workflow to make sure Photo Mechanic is working correctly now. If not, then we recommend re-installing the Photo Mechanic application.

If Photo Mechanic is working correctly now, go to the Preferences and click the Import button. Locate the PM-old-prefs.PMX file from where you saved it earlier and Open it. When the list opens click the Import button to continue. Click the Yes button in the alert dialog to complete the Import. Photo Mechanic will need to quit to save the changes.

Windows

If Photo Mechanic will start up, then go to the Preferences option at the bottom of the Edit menu. Click the Export button at the bottom of the page. After a few seconds a list of selected items will appear. I recommend deselecting the Preferences:Caching entry. This entry will be near the top of the list. Just hold down the Control key and click it to deselect it. Click the Export button at the bottom of the list to save this to your Desktop. Call it something like PM-prefs-<date>.PMX and choose Save. Close the preferences and quit Photo Mechanic.

For Vista, Windows 7/8/10 go to the following location:

C:\Users\<your_account_name>\AppData\Roaming\Camera Bits, Inc\Photo Mechanic

Note: If the AppData folder is not visible, then go to the Explorer Window's Tools menu and select Folder Options. This can also be accessed by entering Folder Options in the Control Panel's search field. Click the View tab and set the option to display Hidden Files and Folders. Apply the changes and then open a new Explorer window.

Click on the Photo Mechanic folder name on the left side of the Explorer window. This will show all of the files and folders in the right panel. Delete the files starting with "com.camerabits.PhotoMechanic". They are preferences files. Close the Explorer window and then restart your PC.

When it's done starting up, check the amount of RAM in your system by going to the System Control Panel. The RAM memory size will be listed by the CPU info. Make a note of the size.

Now start Photo Mechanic. Go to the Edit menu and select Preferences. Click the Import button at the bottom of the dialog and locate the PM-prefs-<date>.PMX file on your Desktop and Open it. A list of items will appear in a few seconds. Click the Import button to continue. Photo Mechanic will open a message box. Just continue with the import.

Next go to the Caching preference page and double check the Memory Cache Size at the bottom. This should be set to approximately 20% of the total system ram size up to 600 MB. Here is a basic guide for PM's Memory Cache size:

Your system RAM PM Memory Cache size
<1 GB 128 MB
1 GB 200 MB
2 GB 400 MB
4 GB+ 600 - 800 MB

Click OK the preference dialog. Quit Photo Mechanic.

Start Photo Mechanic again. Hopefully the problem is fixed.