Scenarios & Solutions

From CameraBits
Jump to: navigation, search
Bob Camera Bits.png

Advanced Photo Mechanic advice from Camera Bits lead technical wizard Bob Russell

Here's where we'll look at some frequently encountered trouble scenarios and walk step-by-step with Bob, using his considerable expertise to solve these knotty problems.


Incremental Ingest mistake - All previously Ingested images are now duplicated.

The Scenario:

You've Ingested to a folder based on the capture date of the images. A new folder is created for each day a photo was shot using the following variable string in the folder name field: {year4}-{month0}-{day0} But, you've accidentally ingested your shoot twice and all of the images from the first shoot are now duplicated in that folder. Each duplicate image has a capital A appended before the file's extension. If a second Ingest was done before checking the Incremental Ingest box, then there will be a second set of duplicate images, all with a capital B appended before the extension.

The Solution:

In the future, check the Incremental Ingest box below the Source path window, in the Ingest dialog. The next Ingest will now just copy the new files since the last Ingest. In the meantime, to clean up the duplicate files now: Follow these steps:

  • Go to the Edit menu and select the Find utility. Make sure you have the Filenames box checked in the Searching section. Uncheck the IPTC data box if it's checked.
  • The In menu should be set to All items.
  • Checking the box for a Case sensitive search will reduce the chance of selecting non-duplicated images.
  • Enter A. in the Find field. (If you have renamed your images during Ingest to have an A before the extension)

Eg, 2015-{seqn}-ATLANTA.CR2, then you will need to enter AA. in the Find field. This will skip any filenames that end in ATLANTA.<ext> and select all of the filenames that end in ATLANTAA.<ext>

  • Click the Find button to select all of the duplicates. You can close the Find dialog by clicking anywhere in the dialog and then hitting the escape key. To verify you have selected just the duplicates, go to the View menu and click the Selected option or use the F2 function key shortcut. Now you can delete the selected images using the Delete Photos option in the File menu.

If you have a second set of duplicates, then repeat the process only using B.<ext> in place of the A.<ext>, in the Find field.


Autocorrect on newer Apple Operating Systems

The Scenario:

Photo Mechanic uses many of the Apple OSX built in features including the spell checker utility. The newer Apple operating systems now have the autocorrect spelling option enabled by default in most applications, which has been a surprise for a few of our customers. This is not a setting that you can change in Photo Mechanic settings, but it can be changed.

The Solution:

You can turn this off by right-clicking in a text area and navigating to "Spelling and Grammar" to uncheck the option "Correct Spelling Automatically."

PM5-Mac-Spellcheck-Options.jpg


Browsing photos taken with iPhone

The Scenario:

You've taken photos with your iPhone and want to browse them with Photo Mechanic, but the iPhone does not mount as a disk, so you cannot ingest as normal with Photo Mechanic.

The Solution:

Bob walks you through the process on YouTube

Configure Windows 10 to launch Photo Mechanic

The Scenario:

You want to launch Photo Mechanic when you click on one of your camera's Raw files in Windows 10

The Solution:

Bob has come up with a PDF that shows you how to configure Windows 10. Download it here